OpenRoads Designer CONNECT Edition SDK Help

LinearIntersectionCollection Methods

Methods

Dispose()  
Dispose(Boolean)  
Finalize (Overrides )
GetEnumerator Returns the enumerator to get the intersections
GetIndexOfNearest Gets the index of the nearest point
GetNearest Gets the nearest point of a LinearIntersectionCollection to a given point
GetVertices Returns intersections coordinates.
Item Gets the intersection at a given location in a collection. Index of the intersection. Start at 1
SetElement1 Defines first linear element for intersections
SetElement2 Defines second linear element for intersections
SortAlongElement1 Sorts intersections along element1
SortAlongElement2 Sorts intersections along element1

See Also